Re: Jedicut muet avec vieille Rustica MM2001 //

#11
Salut,

Le poste que j'ai est pas mal, c'est un bon petit portable de récup avec Win7 et 2 Go de RAM, mais je n'ai pas le mot de passe du Bios. :angry:
D'ailleurs, cela ressemble à un assez gros chantier pour le récupérer.
Je n'entre pas dans les détails, mais la solution consiste visiblement à un démontage assez profond pour effectuer la manip.

Donc pas glop pour s'assurer que le port // est bien en ECP.
Mais effectivement, j'avais imaginé cette possibilité.
Toujours pareil, comme GMFC fonctionne, je n'ai pas creusé plus loin...

En ce qui concerne le câble DB25, il est câblé ainsi :

Image


Je te confirme que tous les connecteurs sont câblés et fonctionnels.

Re: Jedicut muet avec vieille Rustica MM2001 //

#13
I looked at your screenshots and it seems to me that "Vitesse de decoupe" and "Vitesse rapide" values for LPT port control should be much higher between 1000000 and 2500000, with values like on print screens the message "Time Out" appears. For my machine Vitesse is 1600000 and Rapide 1000000 at Nb mm/pas = 0,01. Of course "Estimate" is 0 (at such high values it is not calculated)
Greetings to
Joseph

Translated with www.DeepL.com/Translator (free version)

Re: Jedicut muet avec vieille Rustica MM2001 //

#14
Salut,

As tu réussi à te débloquer ?

Si tu as une MM2001 qui fonctionne avec GMFC, alors ta carte est bonne et il faut que tu appliques les réglages des pins de la MM2001 comme indiqué par Alain.

Avec cette carte, il faut cocher "Synchroniser avec le timer externe". C'est même obligatoire avec le plugin que tu utilises (je confirme que c'est le bon).

Le message "Time out" apparait quand Jedicut n'arrive pas à lire le signal du timer. Il ne faut donc pas voir ce message.

Ensuite les vitesses : si tu as un timer, les valeurs doivent être relativement petite. La fréquence tu timer ne changera rien dans Jedicut (si je ne dis pas de bêtise), cette donnée ne servant qu'à faire des estimations de vitesse.

Est ce que tu as installé GMFC sur le PC qui a aussi Jedicut ? A une époque le driver de GMFC bloqué totalement celui de Jedicut. Même après désinstallation de GMFC qui ne se désinstallé par totalement.

Tiens nous au courant ;)
Jerome

Re: Jedicut muet avec vieille Rustica MM2001 //

#15
Salut Jérôme, salut à tous,

Bon, la vie est mal faite...

Le poste que j'utilise est dédié à la découpe. J'ai une "image" de ce poste, c'est à dire que je peux le formater en un clic, et cela permet de garder une install propre et duplicable, pour le même poste ou pour d'autres postes à peu près identiques.

Donc, oui GMFC tourne sur ce poste.
Oui, j'ai essayé avec et sans le driver du Hotwire.
Et non, Jedicut n'a jamais fait bouger une oreille à ma Rustica.

Dernièrement, après avoir testé 1000 réglages, je m'apprêtai à formater le poste, pour redémarrer d'une install nickel, et là :
Pas de message "Time Out : -1" et Jedicut m'a bougé 2 axes sur 4 (que dans un seul sens, mais quand même !).
Mais quelle victoire !! C'est la première fois que cela se produit.

Donc je me suis dis que c'était juste un PB de valeurs dans l'onglet "Communication" et je confirme les points suivants :
  • 2000 Hz
  • Case "Synchroniser avec le timer externe" cochée
  • Case "Algorithme..." cochée
Donc formatage, réinstallation de Jedicut, et là : rien !
Impossible d'aller plus loin, toujours le message "Time Out :-1".

J'en conclue qu'il faut revoir le paramétrage du port parallèle dans Windows 7 (point que je n'ai pas vérifié avant de formater :angry: ).
Pas taper, pas taper !

Il faudra que je m'y replonge.
Cette expérience m'a permis de mieux comprendre le fonctionnement de la Rustica, notamment les fonctions manuelles de chauffe.
Cela m'a paradoxalement "débloqué" pour faire mieux tourner GMFC. Et j'ai tiré d'assez beaux noyaux qui me posaient souci !!

Mais je suis têtu, et je voudrais bien venir à bout de cette problématique.

Re: Jedicut muet avec vieille Rustica MM2001 //

#16
Salut,

Si tu as formaté, tu as réinstallé Jedicut. As tu bien remis la configuration comme avant, lorsque ça a fonctionné ? C'est à dire le bon plug in, et les bon pin du port parallèle ?

La première chose à faire avec la MM2001, c'est de choisir un plugin compatible, de cocher la case "Synchroniser..." et de faire un test de déplacement des moteurs. Si on n'a pas le message "Time out..." alors Jedicut reçoit bien le signal du timer sur le port parallèle.

Un détail important tout de même : je crois comprendre que tu utilises un environnement virtualisé ? Je n'ai jamais utilisé Jedicut ainsi...

En tout cas tu progresses, c'est cool :)
Jerome

Re: Jedicut muet avec vieille Rustica MM2001 //

#17
Salut Jérôme, salut à tous,

Je suis à peu près sûr de la réinstallation de Jedicut.
C'est à dire la DLL, les valeurs des pas et le sens, et la fréquence.
Je rappelle que je n'avais pu bouger que deux axes avec ma configuration, mais c'était déjà une victoire (plus de message d'erreur).

Par contre, effectivement, je n'avais pas fait le tour de tous mes réglages (notamment le port parallèle).
Donc je ne peux pas reproduire la situation qui marchait !
Et de fait cela ne marche pas...

(Parenthèse Install ON)
Pour mon installation, ce n'est pas un environnement virtualisé, j'utilise une image "Acronis".
C'est un outil qui permet d'une part de faire une image (un gros fichier de plusieurs Go) d'un poste parfaitement installé, système et applications à jour, et d'autre part, il permet de réinstaller ce poste, ou d'en installer un équivalent.
Je m'en sers pour préparer des postes pour les écoles. J'en fais un, le premier, puis je fais l'image Acronis.
Ensuite avec cette image, puis je peux cloner autant de postes que nécessaire (l'installation, ou la réinstallation prend 10 minutes).
Ensuite on active le système d'exploitation, et hop !
(Parenthèse Install OFF)


A bientôt.
cron
`); }); })(jQuery, window, document, phpbb);