Jedicut muet avec vieille Rustica MM2001 //

#1
Bonjour à tous,

Je me présente en une ligne. Je fais partie d'un petit club du Sud-Ouest, suis modéliste depuis très très longtemps et fais voler à 95% des planeurs, en tous genres, à la pente, électriques ou pas, et fais pas mal de remorquage au club sur notre beau terrain.

Depuis longtemps, j'ai une Rustica qui a tiré quelques ailes à l'époque. Elle était un peu dans l'oubli.
Je l'ai remise en route il y a quelques temps après avoir refait les pièces en 3D. Il y a quelques projets au club...
Jusque-là tout va bien, ça fonctionne avec GMFC, mais j'ai pas mal galéré avec cette appli et je voulais passer à Jedicut.
Je pense que j'ai une carte MM2001, sur port parallèle, ce n'est pas moi qui ai monté cette Rustica à l'époque.

Image

En fait, je suis un peu désespéré puisque je suis dans l'impasse.
Encéphalogramme plat pour l'instant !

J'ai parcouru la plupart des posts sur le sujet (et il y en a quelques-uns sur le forum) et Jedicut reste coi.
En gros j'ai repris les réglages préconisés (DLL pour Win7, 0.02083 tours par pas, etc.).
Je ne suis naturellement pas sûr de mes réglages pour les moteurs, mais je me suis inspiré de la doc standard de la Rustica pour attribuer les X,Y et les sens de rotation. Mais est-ce correct ?
Le fait d'avoir aussi GMFC sur le poste pose-t-il problème ?

Voilà, voilà. Je suis preneur de tout conseil pour avancer.
Ou de toute piste, même si j'aimerais bien faire fonctionner l'existant, sans tout changer !!

Merci d'avance.
Modifié en dernier par Gardesan le lun. avr. 27, 2020 7:27 am, modifié 1 fois.

Re: Jedicut muet avec vieille Rustica MM2001 //

#2
Bonjour Gardesan,
Bienvenus sur le forum, Tu dois pouvoir faire fonctionner ta machine avec Jedicut.
Peut-être pourrais-tu nous donner un peu plus de précisions sur ta machine.
Pc utilisé avec quel windows, Nbr pas des moteurs, pas de la vis de transmission.
La version de jédicut utilisé. Dans la barre du Manu : Faire "Aide" puis "A propos".
En attendant voici le dossier de ma machine MM2001
CNCFIL_MM2001.zip
(1.59 Mio) Téléchargé 39 fois
A+
Alain

Re: Jedicut muet avec vieille Rustica MM2001 //

#3
Salut Alain,
Et merci d'avance !

Voici les infos dont je dispose, et les idées et les questions qui me viennent au fur et à mesure.

J'ai un PC portable sous Windows Seven Famille. Un Intel Core 2 Duo avec 2 Go de RAM. Un port parallèle.
J'ai installé la dernière version de Jedicut à ce jour (2.4.1).
Ma machine a des tiges de 6 mm, les moteurs font 48 pas pour un tour, j'ai utilisé la valeur de 0.02083 dans le paramétrage "Machine".

La config que j'ai mise, onglet "Communication" :

Image


Comme lu dans d'autres posts, si je décoche "Synchroniser la rotation..." j'ai un message d'erreur plus tard "TimeOut : -1" et je ne vois plus les vitesses dans l'onglet "Machine". Rien ne bouge, en fait.


Quid de la fréquence (2000, 4000) ?
Quid de "Entrée/Chauffe" ?
Surtout, je ne suis pas sûr de la config du port //.

J'ai utilisé la DLL pour XP, Vista, Seven, mais j'en avais aussi trouvé une autre en cherchant sur le Net...

Autre question, à la lecture du dossier que tu as mis dans ton post, il convient visiblement de manipuler les inters qui sont sur le boitier de commande de la Rustica ??
Jamais fait jusqu'à présent, sauf celui de droite qui arrête tout !
Ce serait bien si tu m'indiquais à quoi ils correspondent ?

Image


Voilà un premier tour d'horizon.
Je rajoute un lien vers le dossier où j'ai mis quelques images et captures d'écran :
https://my.pcloud.com/publink/show?code ... gdmVfsIFiV

A bientôt.

Jean-Jacques.
Modifié en dernier par Gardesan le lun. avr. 27, 2020 7:28 am, modifié 1 fois.

Re: Jedicut muet avec vieille Rustica MM2001 //

#4
Merci des infos,
Pour le PC c'est bon, La version de Jedicut, c'est bon.
Pour la transmission , tige de 6mm le pas est de 1mm et tes moteurs ont 48 step/tour ce qui donne 1mm/ 48 = 0.02083 donc c'est bon.
Le défaut time out, je ne l'ai jamais eu.
Tu peux essayer 2000Hz au lieu de 4000Hz car je ne peux pas te dire dans qu'elle gamme de fréquence ton électronique est.

Pour les interrupteurs : Chaque modéliste fabriquait son boitier autour de la carte, les inters, leds, BP, ne sont pas repéré sur ton boitier.
Ce que je peux te dire il y a 1 inter pour arrêt/marche moteurs, 1 inter arrêt/marche chauffe du fil, 1 inter chauffe du fil par le PC ou en manuel à l'aide des 2 BP + et -.
Led --> MM2001 sous tension, led qui clignote + ou - vite lorsque le fil chauffe., led moteur . Ces BP permettent aussi de modifier la fréquence te de passer en 1/2 pas. Pour que tu puisses bien repérer tes commandes et leds tu ouvres ton coffret et avec les documents de la mm2001 tu suis les fils.
Si tu n'as pas de document sur la MM2001 tu me fais signe.
A+
Alain

Re: Jedicut muet avec vieille Rustica MM2001 //

#5
Bonjour à tous, bonjour Alain,

Bon, ce week-end j'ai "dépoilé" mon boitier, pour suivre les fils et essayer d'y voir plus clair.
C'est un peu vieillot, mais je rappelle que ma machine fonctionne sous GMFC.

En suivant et testant les fils depuis le PIC côté prise du port parallèle, puis de l'autre côté, ça colle à peu près.
Les 4 bornes STEP (9, 7, 5, 3) et les 4 DIR (2, 4, 6, 8) sont bien repérées, ainsi que les 12, 16, 17.
J'ai un petit doute sur la 11 qui ne parait pas câblée comme sur le plan ?
J'ai identifié les interrupteurs et leurs fonctions, les Leds aussi. J'ai découvert l'inter poussoir de remise à zéro (déporté à l'extérieur du boitier).

Je suis passé par là :

Image


J'ai rebranché ce matin, mais hélas, l'encéphalogramme reste plat...


Rien de neuf par rapport à mon premier message :
Avec des réglages un peu plus proches de la vérité (enfin, je suppose), j'ai les mêmes symptômes.
Que ce soit avec 2000 ou 4000 Khz de fréquence, que je coche "New speed algorithm" ou pas les moteurs ne bougent pas.
- Cas N°1, rien avec la case "Synchroniser la rotation..." décochée. Jedicut "travaille, mais c'est tout".
- Cas N°2, avec la case cochée : message d'erreur :

Image


Je suis un peu à l'arrêt, donc ;-((

Peut-être que d'autres pistes sont envisageables ?
Merci de m'éclairer.

Re: Jedicut muet avec vieille Rustica MM2001 //

#6
Bonjour Gardescan,

J'ai repris un ancien PC, j'ai réussi à obtenir le même défaut que toi, ce défaut arrive lorsque le cable DB25 n'est pas raccordé .
Je suppose tout de même que tu as raccordé le câble. est-ce le même câble que pour que pour GMFC ? Normalement si cela marchait avec GMFC, le câble n'est pas en cause.
Il faudrait que tu regardes dans le répertoire ou Jedicut est installé tu dois trouver un fichier "adresse_port_LPT.ini"

Liaisons LPT parallèle :
il n'y a pas de précaution particulière pour le branchement du câble de votre contrôleur CNC à votre PC, en principe il n'y a pas à changer le N° du port dans le fichier "adresse_port_LPT.ini" du répertoire d'installation de Jedicut. En principe : LPT1 --> 0378, LPT2 --> 0278, LPT3--> 03BC ceci si votre PC dispose de plusieurs connecteurs LPT.

Code : Tout sélectionner

[portLPT]
adresse=0378
Si tu ne trouves pas ce fichier dans le répertoire de Jedicut, tu le crées:
- Tu ouvres le Bloc-notes de Windows.
- Tu copies les 2 lignes de code ci-dessus.
- Tu colles ces 2 lignes dans le Bloc-notes.
Tu fais "Fichier" puis "Sauvegarder Sous", tu recherches le répertoire de Jedicut , tu donnes le nom de "adresse_port_LPT.ini" (bien mettre ce nom avec les tirets) et enregistrer.
Lors de l'initialisation de jedicut, ce fichier est lu et ensuite jédicut sait sur quelle connecteur DB25 il faut envoyer les informations à la MM2001.
Si tu as plusieurs DB25 sur ton PC, il faut trouver le bon connecteur et changer l'adresse 0378 par 0278 ou 03BC.
J'espère que c'est ceci qui te bloque.
A+
Alain

Re: Jedicut muet avec vieille Rustica MM2001 //

#7
Salut à tous,

Hélas, mon fichier "adresse_port_LPT.ini" est tout à fait conforme.
Il pointe bien vers le port 0378, comme indiqué.

Alain, tu m'as mis le doute sur l'intégrité de mon câble DB25.
Si j'en trouve un autre, je testerai bien sûr, mais le bon fonctionnement de GMFC me laisse penser qu'une forme de dialogue existe bel et bien entre mon ordi et ma Rustica !!

Je reste à l'écoute de toute piste pour arriver à mes fins et je commence à envisager d'autres pistes pour avancer.

D'une part, on pourrait tester mon boitier sur un ordi dont on est sûr du paramétrage.
C'est peut-être un peu compliqué, d'autant qu'il faudrait le même câblage pour les moteurs, et réfléchir aux modalités.

D'autre part, dans la mesure où ma machine existe, je peux envisager l'acquisition / le montage d'une nouvelle carte de contrôle.
Dans ce cas (mais il faudrait peut-être que je créé un nouveau post), quelle serait la solution la plus simple ?
Je n'avais pas envisagé la suite sous cet angle, donc je vais regarder les différentes pistes proposées sur le site, mais si une solution vous parait évidente par rapport à mon matériel, n'hésitez pas !

Merci d'avance !

Re: Jedicut muet avec vieille Rustica MM2001 //

#10
J'ai regardé comment était mon port LPT1.
Il est en mode ECP et en paramètre, la case " toute interruption est prise en compte" est cochée.
Pour mettre en mode ECP c'est dans le Bios. Tu tapes dans Google Port ECP (LPT1).
Pour le câble, moi j'ai un câble standard fil à fil droit ( c'est à dire que le 1 du mâle va au 1 de la femelle et ainsi de suite jusqu'à 25). attention il y a des câbles qui n'ont pas toutes les connexions.
La position de l'interrupteur de la MM2001 "PC/Manu" n'a pas d'importance, le defaut que tu as n’apparaît que lorsque le câble n'est pas branché
A+
Alain
`); }); })(jQuery, window, document, phpbb);