moteur qui s'affole avec jedicut.

#1
Bonjour a tous,

voila, j'ai un soucis avec ma cnc en cours de mise au point.

en effet, je n'ai pas de mm2001 mais des cartes de recup de moteurs pas a pas.

elle fonctionnent de la meme maniere que la mm2001 avec des signaux pulse(step) et direction (dir).

avec le petit utilitaire lpttest ( http://www.xlentelectronics.nl/LPTTest/ ... ilx64r.htm ), j'arrive a piloter les moteurs en manuel.

une impulsion = 1 pas et changement d'etat sur dir et changement de sens.

jusque ici, normal.

par contre, avec JEDICUT, en mode guillotine, le moteur tourne mais s'affole, change de sens aleatoirement. il semble rentré en survitesse.

je pense avoir un petit soucis mineur du style port // mais je ne vois pas pour le moment. je suis sous XP.

j'allais oublier, j'ai 0.005 pour le nb de mm/pas, 1000 pour la vitesse de decoupe lente (il semble que ce soit une tempo), et 500 pour la vitesse rapide.

voila pour le descriptif.

merci de votre aide

eric

Re: moteur qui s'affole avec jedicut.

#4
J'ai expliqué ça plusieurs fois sur le forum, fait une petite recherche ;)

Tu as 1000 pour une vitesse. Si tu met une vitesse de 100000, est ce que tu as toujours le soucis de l'affolement ? Et si tu mets 1000000 ?

Si tu n'obtiens aucun résultat "normal" lors de ces tests, c'est probablement que tu n'utilises pas la bonne dll. Commander les moteurs en envoyant 1 pas, c'est toujours simple, mais envoyer une succession de pas à une vitesse élevé, c'est une autre histoire et la méthode diffère parfois en fonction de l'électronique de la carte.
Jerome

Re: moteur qui s'affole avec jedicut.

#5
merci Jerome,

en effet, pas de changement notoire en faisant varier la vitesse. meme probleme. d'où mon doute sur la survitesse.

par contre, concernant les DLL, j'ai essayer toutes les DLL de jedicut et le pb est similaire sauf que en effet, les moteurs de 'chantent' pas de la meme maniere.

y a t'il d'autre dll ?

merci

eric

Re: moteur qui s'affole avec jedicut.

#6
bonjour a tous,

voici la suite de l'aventure.

par acquis de conscience, j'ai betement essayer le logiciel de fraisage IPL5X.

et les moteurs fonctionnent...!

donc, la chaine logique pc-carte commande-carte moteurs- moteurs est bonne...!

reste donc en effet un probleme que je ne peut resoudre qui viendrais me semble t'il du logiciel en lui meme et donc en effet, probablement de la DLL.

je ne vois pas autre chose.

si vous avez des idées...

a bientot

eric

Re: moteur qui s'affole avec jedicut.

#9
Bonjour,
Les valeurs de vitesse lente et rapide dont vous parlez me semblent "énormes"...Personnellement j'ai 50 et 15.

A priori d'après le symptome ce n'est qu'un soucis de configuration de Jedicut, soit dans la config des bits du port parallèle, soit dans les valeurs (mm/pas, vitesse...), ou les deux.

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron