problème de téléversement

1
Suite à la conception d'une machine CNC version luxe, je n'arrive pas à téléverser le programme sur ma Mega 2650, ci-joint le message d'erreur voir(photos jointes) ainsi que les éléments suivants:

Jedicut version 2.4.2 pour W 10,
arduino IDE version 1.8.13
sketch LMFAO-V4-7
Restant à votre disposition.

Si cela peut vous aider,
Un ami m'a programmé une carte mega 2650, j'ai ensuite:
mis à jour le pilote dans gestionnaire de périphérique, carte détectée, port com 11,
ensuite j'ai modifié et octroyé les droits dans jédicut,
changé le n° du port com,
vérifié si l'USBSerial_2.dll était bien dans le répertoire DLL
vérifié si le comport.ini modifié était bien dans le racine jedicut,
mais rien y fait, j'entends les moteurs pas à pas prêts à fonctionner mais ne se déplacent pas.
Fichiers joints
capture écran IDE
capture écran IDE
capture message de téléversement
capture message de téléversement

Re: problème de téléversement

2
Bonjour Pascal,

Bravo pour avoir réalisé ta machine.
Quelques précisions :
Si tu utilises le même PC pour téléverser le sketch avec IDE Arduino d'une part et commander ta machine avec Jedicut d'autre part, le logiciel IDE Arduino et Jedicut ne doivent pas être ouverts en même temps. Quand on a téléversé le sketch, on ferme l'IDE et on ouvre Jedicut. L'électronique de ta machine doit être sous tension avant de brancher L'USB et de lancer Jedicut.
Si tu n'utilises pas le même PC pour l'IDE et Jedicut, le port com peut être différent d'un PC à l'autre pour la même carte Arduino.

Pour le défaut de téléversement de L'IDE Arduino, je vois sur tes images que tu as le port com4 de sélectionner alors que tu parles de com11.
Pour Jedicut, tu utilises la version 2.4.2.0, c'est bien la dernière version, Par contre mes notices sont écrites pour la version de Jedicut 2.4.1.x.
Jérôme a amélioré la config de communication dans la version 2.4.2.0 , Il n'y a plus besoin de modifier le fichier "comport.ini", maintenant cela se fait sur l'écran de communication de Jedicut. Je n'ai pas mis mes notices à jour.
Je rédige actuellement le manuel de Jedicut 2.4.2.0, j'ai extrait la partie config des ports voici le lien de téléchargement.
https://drive.google.com/file/d/1eImEW2 ... sp=sharing
Normalement tu devrais avancer sur la mise en service.
A+
Alain

Re: problème de téléversement

3
Merci pour toute ces infos, et de cette rapidité
Je suis bien la procédure de mise en route, 220v, USB puis jedicut.,
Pour le COM4 et le COM 11 dans mon mail précédent, en fait à chaque fois que je fais des essais ou que je change de carte, je dois réinstaller le pilote et le n° de port change.

On s'est aperçu qu'en branchant une autre carte mega 2650 celle-ci n'était pas reconnue, il fallait réinstaller systématiquement le pilote, et le téléversement ne se fait toujours pas avec mon PC, mais sur un autre PC ça fonctionne d'où un problème je pense informatique. Mon PC est neuf et peut être mal paramétré, je me rapproche de mon fournisseur dès demain et vous tiens informé de ce disfonctionnement.

Re: problème de téléversement

4
Bonjour Pascal,

Les cartes Mega 2560 utilisent des circuits intégrés pour l'USB de marque Atmel, le driver est installé lors de l'installation du logiciel IDE Arduino. Aujourd'hui de nombreuses cartes Mega2560 sont des clones et sont équipées d'un circuit intégré pour l'USB chinois CH340G ou CH341. Il faut donc installé le driver de ce circuit , reconnu et accepté par Windows10. Ce driver est téléchargeable chez le fabricant du circuit à l'adresse suivante:
http://www.wch-ic.com/downloads/CH341SER_EXE.html
Regarde sur tes cartes Mega à côté de la prise USB le circuit Atmel est carré, le circuit chinois est rectangulaire.
A+
Alain
`); }); })(jQuery, window, document, phpbb);