Re: Recherche propriétaire MM2001 pour un test

#11
Salut,
J'ai un soucis de section chauffe dans les fichiers jedicut_*.ini : certains paramètres de cette section chauffe (et QUE cette section) semblent remplacé à chaque fois que je lance jedicut...Mais je réponds d'abord à tes questions :

[quote=Jerome]
Je t'invite à télécharger cette version de Jedicut (juste l'exe dans le zip) pour corriger le problème d'interface pour la chauffe
Avec cette version, peux tu :
1 : activer la chauffe dans les options et cliquer sur Ok
[/quote]

Fait, mais ça ne change rien. La case "Activer/désactiver le contrôle de la chauffe" se décoche et les options de chauffe se désactivent dès le click sur OK avant que jedicut revienne à son écran principal.

[quote]
2 : depuis le panneau latéral lancer un déplacement manuel, en ayant activé la chauffe dans le panneau latéral, avec une valeur manuelle de 30%.
ça chauffe si tu fais ça ?
[/quote]

Non. Le panneau de contrôle de chauffe est toujours désactivé, et la chauffe ne s'allume pas lors d'un déplacement...
[img]http://mcd.gomakproduction.com/photos/f ... ptions.JPG[/img]

[quote]
Quand tu quittes puis relance Jedicut, tu retrouves bien la bonne langue, la barre d'outils est affiché selon tes préférences, le panneau latéral aussi... non ? Chez moi ça marche parfaitement.
[/quote]

Oui, je retrouve bien tous ces paramètres là, SAUF en ce qui concerne la chauffe. Il n'y a que certains paramètres de la chauffe qui ne sont pas enregistré, et pire, ils reviennent à chaque fois aux valeurs suivantes :

[pre]
; Activer / Désactiver le contrôle de la chauffe (0-non, 1-oui)
ActiverChauffe =0
...

; Liste des bits nécesaires à la gestion de la chauffe
BitHorlogeExterne =16
BitModeChauffe =15
BitSortieChauffe =22
BitEntreeChauffe =17
BitAlimentationMoteur =23
[/pre]

Même si j'édite le fichier et que je mets les bons trucs (activerchauffe=1 et bonne config des bits) , c'est systématiquement remplacé par les valeurs ci dessus à chaque fois que je relance jedicut, et même sans aller dans les options :S :S
::o ?????

[quote]
Peux tu faire une recherche sur ton PC d'un fichier Jedicut*.ini (même dans les fichiers cachés) ?[/quote]

Dans c:\jedicut :
jedicut.ini
jedicut_default.ini

Dans C:\Users\moi\AppData\Local\VirtualStore\ProgramData\Jedicut :
Jedicut_default.ini
Jedicut_mm2001.ini
Jedicut_rustica.ini

Re: Recherche propriétaire MM2001 pour un test

#13
Salut Vincent,

Peux tu m'envoyer les fichiers qui sont dans le répertoire : C:\Users\moi\AppData\Local\VirtualStore\ProgramData\Jedicut
Tu peux aussi les mettre dans un zip et les envoyer sur le forum.

Je voudrais tester tout ça sur mon PC. C'est comme si il y avait un problème lié à la gestion des tables.

PS : inutile de regarder les fichiers qui sont dans c:\Jedicut. Ils ne sont pas utilisés lorsque des fichiers sont présents dans C:\Users...
PS2 : normal que tu n'ais pas de chauffe si l'IHM te l'interdit (ou te l'autorise à tord...). Mais normalement la version que j'ai posté un peu plus haut corrige le problème.
Jerome

Re: Recherche propriétaire MM2001 pour un test

#15
Salut,

Je crois avoir trouvé, mais si j'ai raison, ce n'est pas une erreur de Jedicut : dans Jedicut, il faut avoir un timer externe pour utiliser la chauffe. Donc si on ne coche pas "synchroniser avec un timer externe", Jedicut n'enregistre même pas la configuration saisie dans l'onglet chauffe.

Peux tu utiliser la version 2.3.2.2 de Jedicut fournit plus haut, cocher "synchroniser avec un timer externe" puis cocher "Activer la chauffe" ? La chauffe doit fonctionner comme avant.
Jerome

Re: Recherche propriétaire MM2001 pour un test

#16
[quote]
Peux tu utiliser la version 2.3.2.2 de Jedicut fournit plus haut, cocher "synchroniser avec un timer externe" puis cocher "Activer la chauffe" ? La chauffe doit fonctionner comme avant.
[/quote]

Aie aie aie, c'est de pire en pire : /

Alors dans l'ordre :

-lancement de Jedicut 2.3.2.2

-J'ai coché les cases "synchroniser avec un timer externe" puis "Activer la chauffe" . Toujours dans les options, je demande un déplacement pour régler V1,C1 etc , avec la chauffe en manuel sur l'interface pour relever ses valeurs, ça fonctionne. Une fois V1 et compagnie reréglées, je repasse donc en chauffe PC sur l'interface.

Mais une fois les options appliquées et quittées, dans le panneau de contrôle, quand on démande un déplacement avec la chauffe à 20% activée, la chauffe s'allume à fond (bonjour le bon de l'ampèremetre !) et les moteurs se bloquent (l'alim on/off moteur est donc bien commandée, mais pas de déplacement). La boite de progression reste alors au début et ne bouge pas. Le bouton "annuler" n'a pas d'effet, il faut fermer la boite de dialogue...Du coup les moteurs restent alimentés et la chauffe allumée...

Si on retourne dans les options, et qu'on refait "tester", là par contre, plus de déplacement, moteurs bloqués, et boite de progression de nouveau plantée...

Voilà voilà :/

En revanche effectivement, avec la case "synchroniser avec un timer externe", les paramètres de chauffe dans les fichiers.ini sont bien enregistrés...Mais pourquoi la chauffe est lié à ce paramètre ? Je croyais qu'il servait uniquement pour garantir un bon fonctionnement des moteurs pas à pas sans que leur vitesse ne dépende des performances du PC ...

Re: Recherche propriétaire MM2001 pour un test

#17
Peux tu me dire si tu observes la même chose avec l'ancienne version de ton plugin et la dernière version de Jedicut que tu utilisais avant ces tests ?

Quand tu coches "synchroniser avec un timer externe", est ce que tu changes les valeurs des vitesses dans les options ? Quand on a un timer, on ne peut pas avoir une vitesse de 50 000 000 mais plutôt une vitesse de 15.

Imagine que Jedicut doive attendre 50 000 000 impulsions timer avant de faire un pas : c'est tellement lent que tu as l'impression que rien ne fonctionne. Et comme Jedicut boucle en surveillant les impulsions du timer, il ne capte pas l'évènement "annulé" quand tu cliques sur le bouton. Et je pense que pour la même raison, l'algorithme de chauffe ne peut pas faire son travail, puisque Jedicut tourne en boucle à cause de la vitesse mal réglée. Le plugin pourrait être amélioré je pense pour rendre plus indépendant la gestion des moteurs et la gestion de la chauffe. Voilà du boulot en perspective, mais qui ne sera utile que pour les personnes configurant mal Jedicut qui applique pour l'instant un postulat important : si on veut utiliser le contrôle de la chauffe, il faut un timer externe, et on est obligé de l'utiliser également pour contrôler les vitesses. Comme écrit plus haut, actuellement, chauffe et contrôle des moteurs sont très imbriquées.

En conclusion, si tu coches "synchroniser avec un timer externe, puis que tu changes les valeurs des vitesses des moteurs, puis tu cliques sur "Appliquer" pour charger en mémoire ces réglages, puis tu configures un matériau si tu veux avec l'assistant de configuration de la chauffe. Ensuite seulement, tu peux tenter un déplacement manuel, d'abord sans chauffe, et si ça marche, tu peux essayer une chauffe de 20%.
Jerome

Re: Recherche propriétaire MM2001 pour un test

#18
[quote]
Quand tu coches "synchroniser avec un timer externe", est ce que tu changes les valeurs des vitesses dans les options ? Quand on a un timer, on ne peut pas avoir une vitesse de 50 000 000 mais plutôt une vitesse de 15.
Imagine que ....
[/quote]

Ah mince, désolé je suis un boulet :P, j'ai complétement zappé ça...bref j'ai remis les vitesses plus adequat (20 en rapide et 40 en lente pour commencer)...Tout rentre évidemment dans l'ordre pour les déplacements via le panneau de contrôle, en chauffe manuelle. Par contre en chauffe PC, la chauffe se mets toujours en route à fond, quelquesoit le matériaux ou la valeur choisi dans le panneau de contrôle (le matériaux est bien sûr configuré tout comme les V1, C1, etc).

J'ai encore oublié un truc ?

Re: Recherche propriétaire MM2001 pour un test

#20
Salut,
Pour être sûr, j'ai refait des tests ce matin avec un bloc d'expanse pour refaire au mieux la config des valeurs de vitesses et chauffe. En effet jusqu'à présent j'avoue que je configurais peut-être un peu trop vite, certes en utilisant "tester" et "enregistrer", mais avec des valeurs de vitesse et chauffe choisie rapidement au pif (V1 et C1 restant toutefois inférieures à V2 et C2 ).

J'ai donc re configuré les C1 V1 etc avec "tester" et "enregistrer", avec un bloc d'expansé cette fois, pour que ce soit "réel". Mais même résultat, la chauffe est toujours allumé à fond quelques soit la valeur indiquée dans le panneau de contrôle ou le matériaux paramétré.

Voici mon Jedicut_rustica.ini.

Et hop, un autre soucis depuis ce matin, après avoir re paramétrée (à priori correctement) V1 C1 etc, Jedicut provoque 2 messages d'erreurs lorsque qu'on le quitte (fichier,quitter) ou qu'on le ferme avec la croix en haut à droite :
[img]http://mcd.gomakproduction.com/photos/f ... edicut.JPG[/img]

puis ensuite :
[img]http://mcd.gomakproduction.com/photos/f ... edicut.JPG[/img]
Fichiers joints
Jedicut_rustica.zip
(1.03 Kio) Téléchargé 17 fois
cron