Re: Pb de définition des tronçons

21
[quote=Jerome]
Tous les plugins cncnet* fonctionne sur le même principe, à moins que vincent ait modifié quelque chose que je n'ai pas vu.
[/quote]

Mon plug-in présente les 2 différences suivantes par rapport aux autres d'origine :
-Il utilise la librairie de communication inpout32.dll (non compatible win95/98) pour pouvoir fonctionner avec winXP, vista et 7.
-Sa dernière version sur googlecode n'a plus de procédure AdapterOrdre, car celle-ci posait problème sous Jedicut 2.3.0 mais pas avec les autres (on en a parlé dans un autre sujet).

je n'ai pas testé sous une version plus récente de Jedicut que la 2.3.0 car vu que ma CNC fonctionne je préfère ne plus toucher à rien :p

Sinon pour le soucis de départ, je pense qu'il s'agit simplement d'un soucis de génération du DXF et/ou du DAT, suivant la provenance du profil qu'on utilise (un dxf converti ou généré avec un logiciel quelconque, un dxf entièrement créé manuellement, un dxf exporté, ou un dxf tout fait qu'on a téléchargé), l'aperçu de découpe et ses points pouvaient parfois être assez fantaisistes : intrados et extrados inversé, bord d'attaque de l'intrados confondu avec le bord de fuite de l'extrados (donc les 2 l'un derrière l'autre), des lignes en trop reliant des points à l'intérieur même de la découpe, intrados au dessus et extrados en dessous, etc etc.

En fait il ne faut pas hésiter à essayer plusieurs dxf du même profil jusqu'à en trouver qui soit parfaitement reconnu par l'aperçu de découpe.

Re: Pb de définition des tronçons

22
[quote=Jerome]Tu as peut être trouvé un bug. Tu peux me décrire exactement ce que tu fais pour constater la remise à 0 de la flèche ?[/quote]

Pour les plugin, je testerais.

Pour le bug, quand je défini les dimensions du tronçon dans l'assistant de découpe, je rentre a flèche au bord d'attaque. Quand j'affiche le cycle de découpe touta l'air correct mais quand je reviens sur l'assistant de découpe la flèche au bord d'attaque est revenue à 0.

Manu

Re: Pb de définition des tronçons

23
Vincent,
Tu devrais au moins remplacer l'exe de Jedicut par le nouveau. J'ai corrigé des petites choses. Au pire tu gardes une coupe du vieux exe ça suffira pour un retour arrière.

Ton dernier message me fait penser à une chose : et si les dernières version du firmware de la mm2001 n'étaient plus compatible avec la méthode AdapterOrdre ? Avant elle était indispensable mais ça ne semble plus être le cas. Je vais supprimer l'appel à cette méthode et proposer les plugin en bêta.

Utilises tu la chauffe via Jedicut sur ta carte ? En manuel PC, en auto ? As tu constaté une inversion du min et du max chauffe en auto dans Jedicut ?
Jerome

Re: Pb de définition des tronçons

25
[quote=Jerome]
Vincent,
...
Ton dernier message me fait penser à une chose : et si les dernières version du firmware de la mm2001 n'étaient plus compatible avec la méthode AdapterOrdre ? Avant elle était indispensable mais ça ne semble plus être le cas. Je vais supprimer l'appel à cette méthode et proposer les plugin en bêta.
[/quote]

C'est possible...Malheureusement je ne suis pas fichu de me rappeler quelle version de firmware j'utilise :p

[quote]
Utilises tu la chauffe via Jedicut sur ta carte ? En manuel PC, en auto ? As tu constaté une inversion du min et du max chauffe en auto dans Jedicut ?[/quote]

Non j'utilise la chauffe manuelle. Et depuis comme j'ai modifié ma MM2001 (certains pins du PIC ne sont plus connectés) pour les test du plug-in utilisant l'API windows, je n'ai plus la lecture des infos de la carte, donc je ne peux pas tester (à moins de re re re re redémonter la carte, refaire les soudures comme avant, mais j'avoue ne pas être très courageux : /)

Re: Pb de définition des tronçons

26
[quote=Jerome]Tu utilises quelle version de Jedicut ? J'ai corrigé quelque chose de similaire. Je vais re tester et je corrigerai dans la prochaine version.[/quote]
La toute dernière en téléchargement. Le fichier Jedicut.exe est daté du 31 janvier 2012 à 21:05.

J'ai fait une réinstallation et j'ai toujours le problème : dans l'assistant de découpe, je rentre ma flèche au BA, je valide. Si je réaffiche l'assistant de découpe la flèche est toujours là :
Flèche disparue.JPG
Flèche disparue.JPG (36.32 Kio) Vu 1935 fois
Si j'affiche le cycle de découpe, la flèche au BA a disparue quand je veux réafficher l'assistant de découpe :
Flèche disparue.JPG
Flèche disparue.JPG (36.32 Kio) Vu 1935 fois
En cherchant un peu, c'est en fait l'affichage de l'assistant immédiatement après celui du cycle de découpe qui pose problème. Si on ouvre une autre fenêtre entre celle du cycle de découpe et celle de l'assistant, il n y'a aucun problème :

- assistant - cycle de découpe - assistant : la flèche disparait
- assistant - cycle de découpe - aperçu avant découpe - assistant : la flèche est toujours là.


Sinon, ce WE, j'ai tenté la première découpe. J'ai créé le fichier jdc sur mon PC perso avec cette dernière version de jedicut et je l'ai chargé dans le PC du club avec l'ancienne version.

J'ai rentré les distances entre les bords de la table et le bloc de polystyrène (il n'y a pas encore de configuration de la table sur cette version), et l'affichage à l'écran me montrait bien la flèche prévue au bord d'attaque.

Seulement, sur l'aperçu avant découpe, cette flèche au BA n'est pas prise en compte (les deux profils emplanture et saumon se superposent au BA) et à la découpe, Jedicut part de la position du fil, fait son dégagement de 10 mm et commence la découpe du profil sans mise en place préalable.

J'ai du positionner manuellement le fil avec le bon angle avant de lancer le cycle de découpe pour obtenir un tronçon conforme à ce que je voulais. Je n'ai trouvé aucun menu qui me permette de rentrer la flèche au BA.

Donc ma question : Est ce qu'il est possible d'installer la dernière version du Jedicut sur le vieux PC du club, et de récupérer les fichiers dll pour conserver les plug-in compatibles avec Win98 ?

Merci d'avance.

Manu
Fichiers joints
Flèche définie.JPG
Flèche définie.JPG (40.36 Kio) Vu 1935 fois

Re: Pb de définition des tronçons

27
Salut,

Je regarderai le bug plus tard mais je voulais répondre à ta dernière question.

Tu peux faire une copie du répertoire Jedicut pour garder cette ancienne version sous le coude au cas où la nouvelle pose problème. Mais l'installateur t'installera les plugin 98 car ils sont toujours prévus. Par contre je déconseille de mettre les vieux plugin sur une nouvelle version de Jedicut car ça ne fonctionnera pas toujours. La structure des plugins peut évoluer de temps en temps.

C'est quelle version à l'atelier ? Ces problèmes de flèche ont disparu depuis longtemps à ma connaissance.
Jerome

Re: Pb de définition des tronçons

30
Merci, je téléchargerais ça.

Sinon j'ai découpé mes premiers tronçons, ça marche pas trop mal.

Par contre, c'est très lent. Dans les paramètres de la machine, la vitesse estimée est de 5 mm/s en vitesse lente et plus de 7 en vitesse rapide, mais dans les réalité, je tourne aux alentours de 1,5 en rapide et 1 en lent (9 secondes pour faire 1 cm).

Les vitesses sont plus importantes avec GMFC. Dans les deux cas, on passe par un timer externe réglé à la même valeur (si ça peut aider).

Alors avec des vitesses aussi lentes, le principe de retourner au BA pour découper l'intrados allonge considérablement le temps de coupe, surtout avec une corde de 37 cm.

Si quelqu'un peut expliquer d'où vient cet écart entre l'estimé et le réel ?

Merci d'avance.

Manu
cron
`); }); })(jQuery, window, document, phpbb);