3 out of 4?

#1
I am running Jedicut 2.4.4 on a 263Mhz Pentium with Windows 2000 operating system and a 4 axis Hobbycnc stepper driver. The Axis X2 motor will not run. X1, Y1, Y2 seem to function properly. The table and all four motors work when run with Foamworks. software.
I have reassigned parallel port pins to exchange motors, however X2 still does not run. The problem follows the axis and not the motor or driver.
Any ideas?

Thank you for the software. I really like the look and GUI

Tim

Re: 3 out of 4?

#3
The board works well. Using foamworks software all four motors are running.
The odd part is that even if I re-assign the axis to a different motor I still have no movement on the X2 axis when using Jedicut. It is as if Jedicut is not able toggle pins 6 & 7 on the parallel port.
Is Windows 2000 an issue?

- Tim

Re: 3 out of 4?

#5
Jerome,
The .ini file is below.
Thank you for taking the time to look at this.

Tim





[General]
;
; Cycle de découpe par Défaut
; CycleDecoupeAile=nombre de phase:type:valeur:lissage:vitesse:qualification:
; Exemple avec une horizontale et une verticale de 10 et 20 avec lissage vitesse découpe, déplacement compté

CycleDecoupeAile=13:1:10:false:1:0:1:4:2000:false:0:0:0:0:10:false:0:1:0:2:0:false:0:1:36:0:10:false:0:1:0:1:10:false:0:1:2:0:10:false:1:2:36:1:10:false:1:2:36:0:10:false:0:1:0:3:0:false:0:1:36:0:10:false:0:1:0:1:10:false:0:1:2:0:10:false:1:2:0:

CycleDecoupeFuselage=12:1:50:false:1:0:1:4:2000:false:0:0:0:0:10:false:0:1:0:6:0:false:0:1:0:0:10:false:0:1:0:1:60:false:0:1:2:0:10:false:1:2:0:1:10:false:1:2:0:0:10:false:0:1:0:7:0:false:0:1:0:0:10:false:0:1:0:1:60:false:0:1:2:

; DllCommunication=Dll choisie par l'utilisateur
DllCommunication=MaxCom.dll

; Etat du Panel de Déplacement (1-non, 0-oui)
PDeplacement=1

; Etat du Panel de Déplacement (1-non, 0-oui)
PDeplacement=1

; Langue de l'interface (=au nom du fichier xml sans son extension)
Langue=English

; Configuration des dernières opérations utilisateur sur le panneau de contrôle
UtilisateurCheckDependance=1
UtilisateurCheckGuillotine=1
UtilisateurCheckLissage=1
UtilisateurCheckChauffe=1
UtilisateurCheckMateriau=0
UtilisateurNumMateriau=0
UtilisateurPourcentageChauffe=10

; FirstLoad=1 si c'est le premier lancement de Jedicut
FirstLoad=0

;[MoteurXX]
;coeffPas=Nombre de mm effectués par pas du moteur
;inverserSens
; 0 : Sens Normal
; 1 : Sens Inverser
;vitesseDecoupe
;vitesseRapide
;bitHorloge=Bit d'Horloge
;bitSens=Bit de Sens

[MoteurX1]
coeffPas=.002645833
inverserSens=0
vitesseDecoupe=1000
vitesseRapide=400000
bitHorloge=5
bitSens=4

[MoteurX2]
coeffPas=0.002645833
inverserSens=0
vitesseDecoupe=1000
vitesseRapide=400000
bitHorloge=9
bitSens=8

[MoteurY1]
coeffPas=0.002645833
inverserSens=0
vitesseDecoupe=1000
vitesseRapide=400000
bitHorloge=3
bitSens=2

[MoteurY2]
coeffPas=0.002645833
inverserSens=0
vitesseDecoupe=1000
vitesseRapide=400000
bitHorloge=7
bitSens=6

[Chauffe]

; Activer / Désactiver le contrôle de la chauffe (0-non, 1-oui)
ActiverChauffe=0

; Lire le mode de gestion de la chauffe sur le port // (0-non, 1-oui)
LireModeChauffe=1

; Liste des materiaux
; ListeMateriaux=nb materiau de la liste:materiau1:valeurChauffe1:materiau2:valeurchauffe2
ListeMateriaux=1:1:30:

; Liste des bits nécesaires à la gestion de la chauffe
BitHorlogeExterne=0
BitModeChauffe=0
BitSortieChauffe=0
BitEntreeChauffe=0

; Synchroniser / Ne pas synchroniser les moteurs avec le timer externe
SynchroniserMoteurAvecTimerExterne=0

Re: 3 out of 4?

#6
try to configure your parallel port in jedicut like this:

try this:

......horloge:..... Sens:
X1....(3).............(2)
X2....(7).............(6)
Y1....(1).............(0)
Y2....(5).............(4)


you don't have to mix between D "bit" in jedicut and Sub-D wiring !! look at the drawing in jedicut configuration board !

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron