communication Jedicut Alden

#1
Bonsoir a tous.
Je viens de finir ma nouvelle machine en 3D a courroie et pour sont utilisation j'ai réalisé la carte de ALAIN Jedicut-Alden V1.2.1
J'ai bien suivi le manuel mais je n'ai pas de réponse avec Jedicut aux test de déplacement .
Pour ceux qui l'on réalisé , au lancement des tests y a t'il des infos qui s'affiche sur l'écran.
J'ai bien essayé les deux pluging dans la fenétre de communication sans résultat .
Il me semble que j'ai la poisse , dèja avec la MM2001 je n'avais pas réussi a communiquer .

Si quelqu'un a une idée ce serait super .
Merci.[attachment=0]bloggif_59e7a84dc31c6.jpeg[/attachment][attachment=1]bloggif_59e7a8e76f71b.jpeg[/attachment]
Fichiers joints
bloggif_59e7a84dc31c6.jpeg
bloggif_59e7a8e76f71b.jpeg

Re: communication Jedicut Alden

#2
bonjour jbmur,

Dans la version 1-2-1 il y a un bug il faut télécharger la version 1-2-1-1, dans le fil des discussion c'est signalé, mais je comprends que c'est pas simple de le voir.
Lien pour le téléchargement du fichier " fcaldenmega_1-2-1-1" . https://drive.google.com/open?id=0BwnRs ... UdXOTNVTlk
Si vous téléchargez le dossier complet il est à jour, la notice aussi.
https://drive.google.com/open?id=0BwnRs ... FBFaU16SEE

Cela devrait fonctionner
Alain

Re: communication Jedicut Alden

#3
Merci Alain .
J'ai mal regardé les données que j'avais hier . J'ai bien utilisé le dernier dossier avec la version 1.2.1.1 mais sur l'écran il ne s'affiche que v1.2.1 donc erreur de ma part.

Mon probléme n'est pas résolu. Je précise que j'ai une nouvelle carte car le problème des picos des micropas est corrigé , la prise ventilateur est là.
J'ai fait le premier test de la carte pour la communication USB c'est OK. Je n'ai pas fait les tests des drivers avec les moteurs car je n'ai pas de carte d'essai et je n'ai pas compris les branchements a faire. J'ai 2 néma 14 et 2 néma 17 . Pour le 14 j'ai 0.8A et 3.6hom donc ref. 0.320v , pour le 17 j'ai 1.5A et 4.7hom donc ref. 0.600v .
Sur la carte breakout quant je lance une commande moteur , je teste une bobine au multimetre et je vois les pulsations d'envoi de courant . Sur la carte ramps je n'ai rien quant je lance un test sur Jedicut.
une photo de ma carte.
A+[attachment=0]bloggif_59e875f086435.jpeg[/attachment]
Fichiers joints
bloggif_59e875f086435.jpeg

Re: communication Jedicut Alden

#4
@jbmur,
Il faudrait que tu donnes à manger aux drivers pour que tes moteurs tournent, il faut brancher le 12v sur le bornier embrochable vert. Comme tu es branché, l'alim est transformée en 5v et les drivers ne sont pas alimentés. Lorsque tu branches le 12 volts sur le bornier embrochable vert le 12v va sur les drivers et sur le régulateur 5v par une diode, tu n'as pas besoin de l'alim actuelle . Tout ceci est détaillé dans le document "Ard_Ramps_IDE.pdf" page 9/28 qui est dans le dossier complet Jedicut-Alden.
A+ alain

Re: communication Jedicut Alden

#5
La photo était pour montrer l'écran . Sur celle là le 12v est branché et un test de Jedicut est lancé, l'écran est toujour le mème et pas de réponse aux moteurs
Il me semble avoir lu que sur la carte arduino des led était active quant elle recevais des ordres du PC. Sur la mienne il y a la verte et la orange allumé en fixe.
Fichiers joints
bloggif_59e89fa3538ab.jpeg

Re: communication Jedicut Alden

#6
Lorsque tu lances la découpe dans Jedicut, la barre de progression va-t-elle lentement et jusqu'au bout ?
Tu devrais avoir une diode qui clignote pendant la progression de la barre.
Tu devrais avoir l'indication de la chauffe égale à celle de jedicut si tu as coché la chauffe.
Tu devrais avoir l'indication de la vitesse en mm/s lors de la progression de la barre même si tes moteurs ne tournent pas.
A+

Re: communication Jedicut Alden

#7
Re bonsoir Alain
oui la barre défile lentement jusqu'au bout
pas de diode qui clignote
je n'ai pas coché de chauffe
sur l'écran rien ne s'affiche

Là je suis aux réglages du drivers avec montage en l'air , j'ai fini par comprendre les raccordements par déduction car sur le plant avec la carte d'essais on ne voie pas le chemin des fils. Je viens de faire le premier test; le moteur tourne bien lentement dans un sens et rapidement dans l'autre sens. les diodes sur la carte arduino clignote bien . je teste tout et je remonte l'ensemble.
A+

Re: communication Jedicut Alden

#9
Bonjour jbmur,
Tu as bien progressé, maintenant il faut voir ces bibliothèques.

Ma version du logiciel Arduino est la 1.8 ou supérieure. Les bibliothèques que mon sketch utilise sont :
"avr/interrupt.h"
"avr/io.h"
"LiquidCrystal.h" à la vue de tes photos, l'afficheur fonctionne.
Ces bibliothèques sont d'office avec le logiciel Arduino, il n'y a pas besoin de les installer.
Je ne vois pas ce qui peut bloquer , tu as bien aussi l'onglet "conf.h " avant de téléverser le sketch ?
Si des lecteurs ont des idées ! nous sommes preneurs.
Tu copies l'erreur lors du téléversement et tu la colles ( "ctrl C et ctrl V") dans la texte de ta réponse en te servant de l'icône suivant "</>" qui se trouve dans la barre sous le message que tu écris. Lorsque tu appuis sur l'icône, des balises "code" sont créées dans le texte, le curseur au milieu des balises clignote, tu fais "ctrl V", ce texte peut faire plusieurs lignes. voici ce que j'aie après la compilation de la version 1-2-1-1

Code : Tout sélectionner

Le croquis utilise 10106 octets (3%) de l'espace de stockage de programmes. Le maximum est de 253952 octets.
Les variables globales utilisent 981 octets (11%) de mémoire dynamique, ce qui laisse 7211 octets pour les variables locales. Le maximum est de 8192 octets.
C'est ce que j'obtiens en faisant la vérification de la compilation en appuyant sur l'icône de gauche genre (case cochée)dans le logiciel arduino.
A+

Re: communication Jedicut Alden

#10
Bonjour Alain , voila la copie de l'erreur.
J'ai dèja utilisé arduino pour modifier mon imprimante 3D , il me demandais une bibliothèque , je lui est donné et je n'avais plus de message d'erreur.
Donc là j'ai toujours ce message mais la liaison arduino et platine communique bien.
Le croquis utilise 10172 octets (4%) de l'espace de stockage de programmes. Le maximum est de 253952 octets.
Les variables globales utilisent 987 octets (12%) de mémoire dynamique, ce qui laisse 7205 octets pour les variables locales. Le maximum est de 8192 octets.
Le croquis utilise 10172 octets (4%) de l'espace de stockage de programmes. Le maximum est de 253952 octets.
Les variables globales utilisent 987 octets (12%) de mémoire dynamique, ce qui laisse 7205 octets pour les variables locales. Le maximum est de 8192 octets.
Bibliothèque non valide trouvée dans C:\Users\jb\Documents\Arduino\libraries\A4988_Test : C:\Users\jb\Documents\Arduino\libraries\A4988_Test
Bibliothèque non valide trouvée dans C:\Users\jb\Documents\Arduino\libraries\application : C:\Users\jb\Documents\Arduino\libraries\application
Bibliothèque non valide trouvée dans C:\Users\jb\Documents\Arduino\libraries\A4988_Test : C:\Users\jb\Documents\Arduino\libraries\A4988_Test
Bibliothèque non valide trouvée dans C:\Users\jb\Documents\Arduino\libraries\application : C:\Users\jb\Documents\Arduino\libraries\application
cron