Re: Jedicut - Arduino - Ramps 1.4

91
Bon, décidément je veux aller trop vite et je fais des bêtises. Je viens de voir mon erreur. Dans le fichier .ini, j'ai mis le numéro de mon port COM mais j'ai pas changé (ou mentionné) le bon numéro avant le ";", conclusion la communication ne se faisait pas. Après modif, tout fonctionne. j'ai déplacé mon unique moteur sur les quatre drivers et tous sont OK. Je suis très satisfait. Demain je m'occupe de l'afficheur provisoire et peut-être du coffret et des différents détails.

Re: Jedicut - Arduino - Ramps 1.4

94
Jerome a écrit : mar. avr. 25, 2017 9:18 pm Salut DigitalBaloo, et bienvenue !

J'ai découvert ton site avec plaisir, et je n'ai pas encore tout vu. ça donne envie d'essayer le FPV. ::clapping::

Reviens vite nous voir avec des photos, et bientôt, de superbe ailes découper avec Jedicut (:D
Merci Jérome, c'est un blog qu'on fait avec mon pote Steven sur notre hobby dévorant (bon c'est surtout Steven qui l'alimente...).
Avec plaisir pour les photos, hâte de commencer tout ça !

Re: Jedicut - Arduino - Ramps 1.4

95
Bonjour,

Aujourd'hui, j'ai câblé mon afficheur provisoire (4x20) et tout fonctionne parfaitement. Je le changerai par celui qui doit arriver dans quelques temps. A ce propos, je me pose une question; Est-ce que l'encodeur présent sur le CI du LCD sera opérationnel pour gérer manuellement la chauffe? Ou bien faut t-il passer à la version luxe du FW?

Merci :D

Re: Jedicut - Arduino - Ramps 1.4

96
Bonjour,
C'est bien si tout se passe comme tu le veux. Au moins mes écritures servent.
L'encodeur n'est actif que pour la version Luxe.
D'autre part, le chauffage manuel dans la version de luxe ne fonctionne que lorsque Jedicut n'envoie pas de signaux. C'est juste pour le nettoyage du fil. En découpe, on ne peut pas être en manuel sur la chauffe, je n'ai pas réussi à caser l’acquisition du potentiomètre ou de l'encodeur entre les interruptions de la liaison avec Jedicut.
Pour moi la version luxe n'est intéressante que pour la gestion des fins de course pour faire le zéro de la machine, et si tu as un cutter électrique pour les découpes des emplacements de servomoteurs.
Si tu n'as pas de fins de course, la version luxe ne vaut pas le coup. Enfin c'est toi qui voit et tu peux très bien faire une carte de commande en câblage.
Bon courage.

Re: Jedicut - Arduino - Ramps 1.4

97
Bonjour,

Nouveau sur ce forum, je souhaite d'abord remercier Jérôme pour la mise en oeuvre de tout ce site autour de Jedicut, ainsi que Alain pour le travail d'adaptation de l'Arduino+ramp1.4.
En effet, je me suis lancé dans la construction d'une machine de type rustica associée à une électronique Arduino+ramp.
La partie mécanique est fonctionnelle (sauf l'arc pour l'instant).
Mais si je me décide à poster c'est à cause d'un (dernier ?) obstacle dans la partie informatique+électronique.

En suivant pas à pas les instructions du dossier Jedicut-Alden, j'ai pu assembler les cartes, les drivers, tester les moteurs, régler les Vréf., tester la carte Ramp, télécharger le sketch fcaldenmega_1-2-1-1, modifier le fichier comport.ini, placer les dll, etc...
Mais c'est en voulant faire un test à partir de Jedicut en déplacement manuel que je bloque : pas de réaction des moteurs et une barre de progression qui s'affiche un quart de seconde. Je pense que la communication entre Jedicut et l'arduino ne se fait pas, mais je ne vois pas comment régler le problème.
Je n'ai pas vu de solution sur le forum.
Quelqu'un aurait une piste pour m'aider ?
par avance merci

Re: Jedicut - Arduino - Ramps 1.4

98
Bonjour Pariou,
Bravo pour ta réalisation, le PC que tu as utilisé pour programmer le sketch est-il le même pour commander ta machine ? Je te demande ceci car les PC ne détectent pas les mêmes ports pour la même carte Arduino. Dans mon cas j'ai un PC pour le développement de l'électronique la carte arduino est détecté en Com4 et mon autre PC pour ma machine détecte la même carte Arduino en Com6. C'est une chose que j'aie découverte au début de mes travaux avec Arduino ; j'avais cherché un bonne demi-journée.
La barre défile très vite c'est que tu n'as pas de dialogue.
Tu as fais la version simple ou la verion affichage ?
A+

Re: Jedicut - Arduino - Ramps 1.4

99
Quelle réactivité sur ce forum !

J'utilise le même PC pour téléverser le sketch et pour faire tourner Jedicut. J'ai bien vérifié que le port COM était inchangé entre les deux étapes.
Pour l'instant j'ai fait la version simple, mais j'étais sur le point de vampiriser un afficheur d'une imprimante 3D pour l'essayer sur cette machine.

Pour info, ma carte ramps1.4 avait également un défaut de court circuit sur les cavaliers MS1 des drivers. Plutôt que de dessouder j'ai laissé ces cavaliers MS1. Donc je suis en demi-pas.

Mes moteurs sont branchés en direct sur la carte, sans utiliser de DB25.

Re: Jedicut - Arduino - Ramps 1.4

100
Bonjour,

Bien venu sur le forum. Ce problème m'est arrivé, il faut relancer Jedicut et en suite alimenter l'interface (Ramps 1.4) avec son 12V. Il faut aussi vérifier en mode manuel qu'il y a bien une valeur d'avance car par défaut il y a 0, donc mettre une valeur positive pour un sens, négative pour l'inverse.

En espérant avoir aidé.

A bientôt
cron
`); }); })(jQuery, window, document, phpbb);