Direction signals not working properly

#1
I've tried using Jedicut with several of the XP DLLs that come with the download and had little joy

With the MaxComXP DLL the steppers all move fine but the direction signals (3,5,7,9) are not changing on the parallel port so they only move in one direction.

With the VisualCNCXP DLL I can get X1, X2, Y1 all moving correctly (in both directions) but the direction signal (Pin 9 of the DB25) doesn't toggle to indicate direction.

I also find on the VisualCNC XP DLL that I can not vary the step-rate of the motors and they step exceedingly slowly (external timer is de-selected and I *can* vary the step speed on the MaxComXP DLL).

Any ideas?

Running Windows XP and I've tried two machines just to verify that there's not a hardware fault. This machine also runs the Linux-based EMC CNC software with no problems at all so I don't think it's hardware.

One clue -- both machines on which I installed JediCut came up with an error that said soemthing like "unable to connect with IO.sys but it is running" when first started. Is this normal? The error message has not reappeared.

Re: Direction signals not working properly

#2
Hi,

If your motors don't work in the both direction, you may not choose the right dll or you're board is not compatible with Jedicut 's dll. What kind of CNC board do you use ? Do you have a hobby cnc board, a MM2001 or a visual CNC board ?

I don't know why you see the message "unable to connect...". But if this message desappears it's good :p
Jerome

Re: Direction signals not working properly

#5
Hello Jerome
I to have a direction problem. I am using a MM2001 board I have built up.
The four axis are working in one direction only, if I put a negative number like -10mm to travel in manual
the axis will not reverse. I have checked the parrallel port and get the correct step and direction to the pic chip for the four axis but have no reverse direction. I also tried FoamWorks with the same problem.
The speed of the axis is not slow like others have said on the forum.
Can you help with this problem.

Regards Steve

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron