Jedicut crashing

Hello all, I´m using Jedicut for a while and everything was working fine, Suddenly it started to stop working in random parts of the cut, I´m using win 7 with an arduino uno board, The problem started when I tryed to cut a wisel wing using PW51 profile. Jedicut was the last software installed. The only way to get back the CNC control (mnual mode) is if I turn Jedicut of and on again. Doing the same with the arduino does not change anything. Everything worked fine until the last weekend. Has anyone experienced this behaviour?
Best regards

Re: Jedicut crashing

I will try to refine the problem: I´m using a pw51.dat or pw1211.dat or ag03.dat profiles. All gave the same result. The machine starts to cut and suddenly the progress bar freezes, and I can not do nything else. I have to shutdown Jedicut and reinialize it to get control of the motors again. The freezing point is ramdon. Even if using the same profile it freezes in different position. Has someone experiences some thing like that?
P.S. The electronics/communications are working well.