my machine, precise but not stable!

#1
Hi Jérome, Hi Alain, Hi Cutters,

first i want to thank you for this wonderful piece of software and the great ideas of you and the community members!
My name is Jeremy. Having a 3d Printer and a cnc-router i used these machines to bild a cnc hotwire cutter. I had a lot of fun building and the results are great, but sometimes ( approx. one out of three times) my machine suddenly stops cutting. I tried to figure out what the reason is, but dont really know, as it seems to me that it is related to usb Communication or timer calculation or something else. So i wanted to ask if someone has similar problems or might have an idea whats the reason. Here are the specs of my machine, if you need more information, please let me know:

Software:

Jedicut - Alden 1-2-3 with a LCD

Electronics:

Arduino Ramps 1.4,
4899 Drivers, microstepping set to 1/8
12v 47A Power Unit conncted to both Voltageinputs on Ramps
NEMA 17 Motors 12v

Hardware:

Wooden construction with Slides, running very smooth. X-axis 53cm travel, Y-axis 40 cm travel
Threaded Rods 8mm diameter with 8mm Pitch
Hot wire 0,5mm / 0,4mm / 0,25mm , Length adjusteable, Wire in a seperate bow.

Configuration:

Uploaded latest Version, set correct COM Port in the .ini File, Baudrate 115200
i have 0,05mm per Step,
Slowspeed is set to 176 which gives me a Speed of 1,75mm/sek
Fastspeed is set to 64 which gives me a Speed of 4,89mm/sek
The Hz i use is the default 62500 as i read somewhere to leave this untouched.
Temperatur controll works fine.


So if i am cutting, the machine starts normal and sometimes suddenly stops / crashes. It does not reboot, The motors in that case still have power, and the wire is still heating but its not moving anymore. This actually never happens within a specific part of the Cut, but mostly exactly between two steps, for example: Moves to start hight / Pause/ moves horizontal 10mm / and then it stops, exactly when it should start to cut the upper wing side. Sometimes the same happens at the end of the upper side ore just befor it starts to cut the lower side.
So i thought the problem it is related to power as at these specific points the machine has to run all 4 motors at a time, but the power unit is big enough (47 A at 12,2V and i tried by Powering from a big 3s Lipo as well without a positiv effect) and if i drive manually (oblige) it works without any problems.

I tried a different Arduino Ramps Board, same problem. Also different USB Ports and Cables
I tried bigger Stepper drivers, motors work much louder and get hot but same problem.
I tried different reference-voltage for the steppers, no positiv effect.
I tried to reduce Microstepping to 1/4, machine runs rough and loud, but still the same problem.
I trtied to insert a pause of 100 ms between each step in cycle of cut manager, machine crashed and moved extremly slow 0,08mm/sek in wrong direction.


If it runs, th results are great, the machine is very precise, i cut Airfoils, Letters, Fuselage from .dat and from .dxf and it is totally cool and fascinating, i simply would like to have it to run more stable as i already filled 5 big waste-Bags of Styrofoam and XPS...

Any Help is welcome, and is there a way to attache Pictures without uploading to an external server first?


best regards, Jeremy

Re: my machine, precise but not stable!

#2
Bonjour Jap,

Effectivement il y a un problème avec la nouvelle version de Jedicut 4.1.0.
Il faudrait que tu utilise le sketch pour l'arduino mega LMFAO_1_4
En téléchargement ICI
https://drive.google.com/open?id=1tV9f6 ... sPj-CREWka

Les options à ta disposition:

Code : Tout sélectionner

 #define MACHINE_NAME "  CNC FIL AERODEN"   //Tu peux changer le nom de ta machine se limiter à 20 cacactères entre le guillemets.

#define LANG_FRENCH
//#define LANG_ENGLISH    // peux choisir entre Français et anglais.

#define MM_PER_STEP 0.0025 // tu mets ce que tu avais sur ta machine.
#define INV_DIR_MASK 0b00000000 // "1" inversion des 4 axes -> 0b11110000 tu ne touches pas c'est pour la Super Luxe pour le homing.
---------------------------------------------------------------------------- / If the Stepper Driver has an inverted enable pin level, uncomment this
//#define INVERT_STEPPER_DRIVER_ENABLE_PIN

#ifdef INVERT_STEPPER_DRIVER_ENABLE_PIN
    #define    STEPPER_DRIVER_ENABLE_HIGH_LEVEL 1
    #define    STEPPER_DRIVER_ENABLE_LOW_LEVEL 0
#else
    #define    STEPPER_DRIVER_ENABLE_HIGH_LEVEL 0
    #define    STEPPER_DRIVER_ENABLE_LOW_LEVEL 1
#endif
 Pour ceci tu ne touches à rien c'est pour les drivers individuels qui ne sont pas sur une carte Ramps1.4
----------------------------------------------------------

# define CHAUFFE_ASSERV 0 // "0" pas de chauffe asservie, "1" chauffe asservie
# define CORRECT_CHAUFFE 1.32 // coefficient de chauffe en fonction vitesse
Ceci fonctionne bien,

Voila tu vas pouvoir utiliser Jedicut 4.1.0 car la partie table de matériaux et les changements de chauffe fonctionnent lorsque la vitesse change dans Jedicut.

A+
Alain

Re: my machine, precise but not stable!

#3
Hi Alain, thanks for your fast reply, that was a big help! I uploaded the new sketch to my arduino, set it to english language, as this is easier for me. also i changed that the motors are piloted and not have power all the time. Then i put in the parameters of my machine and did a testrun in manual mode. It worked for simple movements, but when i activated heating it didnt work correct. The heating was ok, but it went extremly slow at 0.01mm/sek. After changing some settings in Jedicut Options, especially disabeling "dynamic heating control" it worked fine.
I then did three test cuts, Wing, Fuselage, free shape without any problems or chrashes - this is fantastic, i hope it will stay like that. Will do further cuts, see if it runs stable, but for the moment that was the Help i needed! Thank you - mercie bien!

Jeremy

Re: my machine, precise but not stable!

#4
Hi Alain, my machine is running stable now, thanks for your help. I have two more questions, maybe you can help me, as it might be, that they are related to the new sketch 1.4.0 aeroden.

First: in cycle of cut manager, the PAUSE is not working. No matter which value i set, it cuts without pause. It would be a big help to have this pause as this time is needed for my hotwire to heat up, befor cutting into the material.

Second: Which settings do i have to activate to get dynamic heat control, schould i set the value in the sketch or in the jedicut software or both?

Thanks in advance, Jeremy

Re: my machine, precise but not stable!

#5
Bonjour

La pause ne fonctionne pas avec les nouveaux sketch, nous allons travailler pour rétablir la pause.
En attendant il faut faire un ligne avant la découpe avec la chauffe.
Pour la chauffe asservie il faut mettre un "1" à la place du "0" dans la première ligne dans le sketch. et ne rien faire dans Jedicut.

Code : Tout sélectionner

# define CHAUFFE_ASSERV 0 // "0" pas de chauffe asservie, "1" chauffe asservie
# define CORRECT_CHAUFFE 1.32 // coefficient de chauffe en fonction vitesse

A+
Alain