Re: Aide pour maj de table

#71
Bonjour André,

Si la prise cylindrique correspond à la bonne polarité et au diamètre tu peux la brancher directement sur l'Arduino, dans ce cas l'électronique fonctionne (afficheur) par contre le 12v ne remonte pas sur la ramps 1.4 car il y a une diode de protection entre la carte méga et la carte ramps.
Pour alimenter les drivers il faut absolument que tu passes par le bornier de la ramps 1.4.
Avant de brancher sur le bornier, tu vérifies que les radiateurs en alu des drivers ne touchent pas le potentiomètre de réglage de la tension de référence du courant du driver, ils sont très près mais ne doivent pas toucher un composant.
Je te recommande d'utiliser la dernière version du sketch LMFAO_V4_5_0. Pour les fins de courses, tu ne les shuntes pas, il te suffit dans la configuration des lignes suivantes de ne pas mettre le homing et le pré-positionnement en service.

#define SEQ_HOMING 0

#define PREPOS 0

Code : Tout sélectionner

/*=============================================================================
Ces paramètres déterminent les différents types de séquence Homing
*/
#define SEQ_HOMING 0 // "1" sequence Homing active, "0"  Pas de sequence Homing
#define POS_SECU_Y 1  // "1" exécute une remonté des Y avant le homing
#define MM_POS_SECU_Y 2 // valeur de remonté des Y de x mm avant le homing
#define PREPOS 0 // "1" Pré-positionnemnt après homing permis, "0" pas de 
                 // pré-positionnement
#define MM_PREPOS_Y 1 // Valeur en mm de la distance du pré-positionnement Y
#define MM_PREPOS_X 1 // Valeur en mm de la distance du pré-positionnement X
La machine fonctionne sans les fins de courses.
N'oublie pas de disposer les chariots de ta machine à distance des butées mécanique pour les essais de sens de rotation.
Normalement tu peux ne pas brancher tes moteurs (les câbles DB25) et mettre sous tension l'électronique. Ensuite si tu veux rebrancher les moteurs il faut mettre hors tension l'électronique attendre 1mn que tous les condensateurs se déchargent. Ce n'est qu'après que tu peux rebrancher les moteurs puis remettre sous tension. Il ne faut jamais débrancher ou rebrancher des moteurs en ayant l'équipement sous tension.


A+
Alain

Re: Aide pour maj de table

#72
Bonjour,
je suis de retour après avoir laissé de coté la machine..
je reprends doucement afin de la finaliser....
j'ai quand meme un peu avancé car j'ai fait les support de fdc via l'imprimante 3d.
Ce matin j'essaie de remettre en marche mais impossible de faire bouger les moteur.
J'ai repris l'ensemble des infos mais je ne trouve pas la solution :
J'ai vérifié le port com: ok
le sketch :ok
la machine est reconnue : ok : car quand je quitte jedicut l'arduino se relance.
modif du sketch pour virer les fdc : ok :
Paramètres pour permettre le calcul des données nécessaires à la mise à zéro
de la machine
*/
#define VIT_RECH_FDC 4.50 // Vitesse de recherche fdc en mm/s Format XX.XX
#define VIT_AJUST_FDC 1.00 // Vitesse d'ajustement fdc en mm/s Format XX.XX

/*=============================================================================
Ces paramètres déterminent les différents types de séquence Homing
*/
#define SEQ_HOMING 0 // "1" sequence Homing active, "0" Pas de sequence Homing
#define POS_SECU_Y 1 // "1" exécute une remonté des Y avant le homing
#define MM_POS_SECU_Y 2 // valeur de remonté des Y de x mm avant le homing
#define PREPOS 0 // "1" Pré-positionnemnt après homing permis, "0" pas de
// pré-positionnement
#define MM_PREPOS_Y 1 // Valeur en mm de la distance du pré-positionnement Y
#define MM_PREPOS_X 1 // Valeur en mm de la distance du pré-positionnement X

vérification des câbles : a priori ok et tester avec l ohm mètre

Par contre quand je passe sur inter PC le buzzer se fait entendre...

branchements :
[url][/url]
[url][/url]

A l'aide.....la déprime me reprends

Re: Aide pour maj de table

#73
dans la recherche de la vérité :
j'ai refait un test des pololu :
vérification du voltage : ok
sketch televersé : ok
test ramps1.4 : ok

conclusion : ramps ok
problème de communication entre jedicut et arduino

maj a 12h44
j'ai téléversé le schetch 2.4.3 : même constat , j'ai le buzzer qui sonne en permanence....
mais rien ne bouge
arduino interagit avec jedicut = le buzzer s arrête de sonner lors du lancement et la fermeture de jedicut

maj de 15:24
téléversement du sketch 1.5
et ça fonctionne : les moteurs bougent
bilan problème avec la version panneau de contrôle pourtant tout les potards fonctionnent
est ce que je dois faire une modif ?

Re: Aide pour maj de table

#74
Bonjour André,
Je suis heureux que tu te remettes sur ta machine, tu es très près du but, nous allons reprendre point par point les réglages.
Merci pour toutes les infos que tu donnes, par contre je vais te demander un peu de temps (1 journée) pour que j'analyse tes essais, Actuellement je suis sur d'autres projets, il faut que je me remette en tête la découpe fil chaud.
En attendant, est-ce que tu peut me dire la version de Jedicut que tu utilises. La dernière version de Jedicut 2.4.1.3 je ne l'ai pas encore testé.
A la vue des photos, ton câblage est parfait.
A+
Alain

Re: Aide pour maj de table

#75
Bonjour alain
C est la derniere version de jedicut car dans le doute j ai desinstaller et reinstaller.
Je dirais que mon soucis viens des fins de course. J ai commandé les condensateurs afin de finir....enfin 😁
Si ça peut aider dans l origine de la cause sous la derniere version alden pour la mise en service :
Mode pc
Moteur on
J arrive sur l affichage des fins de course
Obligé d appuyer sur le bouton et il me demande de repasser le bouton sur off
J ai le buzzer qui se fait entendre.....

Re: Aide pour maj de table

#76
Salut André,
Il me semble aussi que ce soit les fdc qui te bloquent.
De toute façon, il faut les 4 condensateurs de 100 nF pour un fonctionnement correct.
En attendant de mettre tes condensateurs, tu as une séquence d'aide de mise en service des fdc et de vérifier leur sens.
Dans la doc CNC Fil chaud Jedicut Alden Super Luxe (AD/JED/JASL01) tu respectes bien à partir de la page 30/49.
Il faut que tu tournes le potentiomètre de la chauffe à fond dans le sens des aiguilles d'une montre pour que le programme passe par la séquence d'aide à la mise en service des fdc. Sans Appuyer sur les fdc tu dois voir des zéros, si tu as des 1 c'est que tu n'est pas sur la bonne borne du fdc . Tu as sur les fdc 3 bornes C, NF, NO ; tu dois utiliser C et NF, le contact est fermé lorsqu'il n'est pas sollicité. Sur l'écran, lorsque tu sollicites un fdc tu dois avoir un 1 et tu vérifies si ce fdc correspond bien au mouvement X1, X2, Y1 et Y2. si ce sont des fdc que tu ne peux pas inverser, tu peux le faire dans le sketch. Tant que ceci n'est pas OK le homing ne fonctionnera pas.
Dans le dossier général il y a un dossier fdc pour toutes les explications. Tu es dans la partie la plus difficile de la mise en service, bien lire mes notices et tu y arriveras.
A+
Alain

Re: Aide pour maj de table

#77
Merci pour ton aide
J ai commencé la lecture des notices 😉
Je ferai un retour dès reception des condensateurs

Je prepare mon hiver....qui sera orienté construction

Maj : je viens de lire le dossier complet sur les fdc
Beau boulot
J ai juste un peu de mal au niveau des branchement sur la ramps ... apres je lis le dossier sur mon telephone.
J ai la chance d avoir des fdc mecanique a 3 fils.. youpi je dois rajouter une borne 5v

Re: Aide pour maj de table

#78
je suis trop content....je viens de tester les fins de course....et miracle ça marche
ça communique avec jedicut

allez dernière ligne droite avant les premiers tests de découpe : impression des derniers supports de fdc, branchement du fil chaud et mise en route
avec un peu de chance c'est fini ce week end

petite question utile : j'ai peur depuis avoir cramé la dernière alim de rebrancher sur la prise. Alain pourrais tu vérifier mes branchement stp, a priori ça me parait correct.
[url][/url]

Encore merci alain

Re: Aide pour maj de table

#79
Bonjour André,

Bravo ! Je ne suis pas en accord avec toi car en électronique ou en programmation il n'y a jamais de miracle. C'est tout simplement toi qui a appris et compris les choses ce qui te fait arriver, par ta persévérance à l'objectif que tu t'es fixé. Encore bravo.
Maintenant il te reste un point, le branchement de ton bloc interrupteur et fusible. A la vue de la photo, ton alimentation n'est pas morte car il me semble que ce n'est pas bien branché.
Voici un croquis qui devrait te permettre de mettre en ordre.

Image

Ton bloc inter + fusible est doté d'un interrupteur lunineux et de 2 contacts, le voyant interne à l'interrupteur est relié au 2 bornes les plus écartées,, ton câble qui va vers l'alimentation doit être branché sur ces bornes marron (L) , bleu (N), et la terre vert jaune (T) est bien branché comme sur la photo.
A+ pour la suite.
Alain
cron
`); }); })(jQuery, window, document, phpbb);