Re: Adaptateur arduino nano MM2001

21
Bonsoir,

Même si la mm2001 n'est pas reliée, vous devez avoir un défilement plus lent de la progression. Les led vertes doivent clignoter et la rouge peut s'éteindre et se rallumer lorsque le buffer de réception de l'arduino est presque plein.
Je vais essayer de faire des essais avec mon ancienne MM2001. En attendant, vous pouvez lire le post Jedicut Arduino Ramps. Je donne d'autres infos qui peuvent peut être vous éclairer.
A+
Alain


.
Je vous invite sur mon blog :
http://alainfelixdenis.wordpress.com/
sur mon site :
http://www.aeroden.fr

Re: Adaptateur arduino nano MM2001

23
Bonsoir,
Aujourd'hui j'ai câblé une carte avec un Nano et une DB25. Je vais descendre mon équipement MM2001 du grenier, demain j'essaye de mettre tout cela en route.
Pouvez-vous me communiquer vos équipements mécaniques:
nbre de pas par tour des moteurs pap,
pas de la vis d'entrainement des chariots, ou autre si c'est par courroies
la vitesse de découpe et la vitesse rapide que vous voulez obtenir.

Cela me permettra de vous donner la config de Jedicut.
A+ Alain
Je vous invite sur mon blog :
http://alainfelixdenis.wordpress.com/
sur mon site :
http://www.aeroden.fr

Re: Adaptateur arduino nano MM2001

24
bonsoir alain,
je veux bien essayer, mais pour moi, le problème ne vient pas de la config de jedicut, mais plutôt du " dialoge " entre le pc et l'arduino,
pour moi, soit le fait que l'on utilise w7 tout les deux pose un problème de communication, soit le dll n'est pas compatible avec cette version de Windows.
mais bien sur, ce n'est qu'un sentiment
apres si tu veux ma config,

carte de gestion hobby cnc
100 pas par tour aux Y coeff pas0.005
96 aux X coeff pas 0.00521
tige filletée M6: 1 mm/tour
vitesse rapide 4
vitesse decoupe 4
https://www.adal.club/index.php

Re: Adaptateur arduino nano MM2001

25
Bonjour,

Y'a pas de probleme avec Windows 7... Ni avec windows 10. Les deux marchent chez moi.

Faut bien sur bien numeroter le numero du port serie quand on branche la nano, et editer le fichier .ini du plugin pour mettre le bon numero du port.
J'ai pas change le baudrate, et laisse 115200. Et ca march sur le mega. Vu que la nano a le meme processeur... Ca doit aussi marcher, y'a pas de raison.

Olivier.

Re: Adaptateur arduino nano MM2001

26
Je parle du fichier Comport.ini, dans le repertoire Jedicut

------------------------------------------------
; COM Settings (comport.ini)
;------------------------------------------------

;
[COMPORT]
PORTNUMBER = 12 ; COM12
BAUDRATE = 115200 ; 110,300,600,1200,2400,4800,9600,14400
; 19200, 38400,56000,57600,115200,128000,256000

Re: Adaptateur arduino nano MM2001

27
salut,
ce qui m'embête , c'est que je pense avoir tout ca.
un fichier créé dans le répertoire de l'application jedicut, : comport.ini
avec le port, qui est ouvert dans le gestionnaire de perif: pour moi port com 14 ( d'ailleurs c'est le même que j 'utilise pour flasher l'arduino)
le dll, serial USB rajouté dans le répertoire des dll
j'utilise un arduino uno, c'est franck qui utilise une nano, mais il n'a guère plus de succès.
pour repondre a alain

il y a 4 led sur ma carte, deux qui restent constament allumés, ON et L (?) et deux autres le rx et tx qui ne s'allument jamais.

que la carte arduino soit branché ou pas, le défilement de la barre de progression est pareil.

hugo
https://www.adal.club/index.php

Re: Adaptateur arduino nano MM2001

29
Bonsoir,

J'ai un peu travaillé sur le nano, voici les copies d'écran des configurations
Cliquez droit sur le lien et choisir ouvrir dans une autre fenêtre ou onglet, ce sera plus pratique pour lire le texte et voir l'image.


Suite à vos organes mécaniques il faut procéder à la config de jedicut Voir les images de configuration: Onglet Communication, bien choisir la dll, et mettre 62500 dans la fréquence Timer, le timer est dans l'arduino. Quelque soit votre électronique de puissance, il faut configuer les bornes de la DB25 comme sur la photo. C'est ensuite que vous relier les pins de l'Arduino sur votre DB25 selon vos axes et vos commandes de moteur.

Passez ensuite à l'onglet "Machine" mettre 0.005 dans les cases pas par tour je suppose que vos drivers de moteur PAP sont en 1/2 pas.
Changez les coefficients pour avoir les bonnes vitesses d'affichage. Pour les essais de communication mettez des valeurs entre 63 et 127.

Pour le mise en oeuvre de l'USB ouvrez la fenêtre périphériques, développez les USB vous devez avoir une ligne identique à celle entourée "USB Serial Converter", développez les ports de communications et vous devez avoir le port com qui s'appelle "USB Serial Port (comX)" sur ce port cliquez droit et Propriété, vous devez avoir FTDI ou arduino en Fabricant.
Avec ceci vous devez communiquer: les led vertes doivent clignoter, la PWR reste allumée, la 4 eme peut s'éteindre et se rallume à la fin de la transmission.

Pour les essais, je fais des guillotines par axe et j'ai vérifié à l'oscillo le fonctionnement. Ce sont les autres photos, dont la commande de chauffe à 50%.

Dans le programme arduino il y une modif à faire pour que les vitesses soient exactes et que le déplacement soit conforme en distance. Je l'explique dans la discussion " Jedicut Arduino Ramps "

Un inconvénient de l'USB, il me semble qu'il est préférable que tous les moteurs PAP soient identiques. à vérifier !

Bon courage
Je vous invite sur mon blog :
http://alainfelixdenis.wordpress.com/
sur mon site :
http://www.aeroden.fr
cron
`); }); })(jQuery, window, document, phpbb);